Overview

Cisco has announced a vulnerability in the NX-API feature of Cisco NX-OS Software could allow an unauthenticated, remote attacker to craft a packet to the management interface on an affected system, causing a buffer overflow.

The vulnerability is due to incorrect input validation in the authentication module of the NX-API subsystem. An attacker could exploit this vulnerability by sending a crafted HTTP or HTTPS packet to the management interface of an affected system with the NX-API feature enabled. An exploit could allow the attacker to execute arbitrary code as root.

Note: NX-API is disabled by default.

Cisco has released software updates that address this vulnerability. There are currently no workarounds that address this vulnerability.

 

Vulnerable Platforms

TNote: NX-API is disabled by default.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

  • MDS 9000 Series Multilayer Switches
  • Nexus 2000 Series Fabric Extenders
  • Nexus 3000 Series Switches
  • Nexus 3500 Platform Switches
  • Nexus 5500 Platform Switches
  • Nexus 5600 Platform Switches
  • Nexus 6000 Series Switches
  • Nexus 7000 Series Switches
  • Nexus 7700 Series Switches
  • Nexus 9000 Series Switches in standalone NX-OS mode
  • Nexus 9500 R-Series Line Cards and Fabric Modules

 

Fixed Software Releases

MDS 9000 Series Multilayer Switches: CSCvd45804

  • 5.2 migrate to version 8.1(2) or 8.2(1)
  • 6.2 migrate to version 8.1(2) or 8.2(1)
  • 7.3 migrate to version 8.1(2) or 8.2(1)
  • 8.1 migrate to version 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 3000 Series Switches: CSCve02322

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 3500 Platform Switches: CSCve02322

  • 6.0 migrate to 6.0(2)A8(8) or 7.0(3)I7(4)
  • 7.0.3 is not vulnerable

 

Nexus 2000, 5500, 5600, and 6000 Series Switches: CSCvd45804

  • 6.0 is not vulnerable
  • 7.0 is not vulnerable
  • 7.1 is not vulnerable
  • 7.2 is not vulnerable
  • 7.3 migrate to 7.3(2)N1(1) or 7.3(3)N1(1)
  • Nexus 7000 and 7700 Series Switches: CSCvd45804
  • 6.2 is not vulnerable
  • 7.2 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 7.3 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 8.0 migrate to 8.1(1) or 8.1(2) or 8.2(1)
  • 8.1 is not vulnerable
  • 8.2 is not vulnerable

 

Nexus 9000 Series Switches in standalone NX-OS mode: CSCve02322

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not affected

 

Nexus 9500 R-Series Line Cards and Fabric Modules: CSCve02412

7.0 migrate to 7.0(3)F2(1) or 7.0(3)F3(3a)

 

Further Information

Cisco’s security advisory for this vulnerability can be found here https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-nxos-bo

 

Overview

Cisco has announced a vulnerability in the Cisco Fabric Services component of Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated, remote attacker to execute arbitrary code or cause a denial of service (DoS) condition on an affected device.

The vulnerability exists because the affected software insufficiently validates Cisco Fabric Services packet headers when the software processes packet data. An attacker could exploit this vulnerability by sending a maliciously crafted Cisco Fabric Services packet to an affected device. A successful exploit could allow the attacker to cause a buffer overflow condition on the device, which could allow the attacker to execute arbitrary code or cause a DoS condition on the device.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

 

Vulnerable Products

This vulnerability affects the following Cisco products if they are running a vulnerable release of Cisco FXOS Software or Cisco NX-OS Software and are configured to use Cisco Fabric Services:

  • Firepower 4100 Series Next-Generation Firewalls
  • Firepower 9300 Security Appliance
  • MDS 9000 Series Multilayer Switches
  • Nexus 2000 Series Fabric Extenders
  • Nexus 3000 Series Switches
  • Nexus 3500 Platform Switches
  • Nexus 5500 Platform Switches
  • Nexus 5600 Platform Switches
  • Nexus 6000 Series Switches
  • Nexus 7000 Series Switches
  • Nexus 7700 Series Switches
  • Nexus 9000 Series Switches in standalone NX-OS mode
  • Nexus 9500 R-Series Line Cards and Fabric Modules
  • UCS 6100 Series Fabric Interconnects
  • UCS 6200 Series Fabric Interconnects
  • UCS 6300 Series Fabric Interconnects

 

Fixed Software Releases

Firepower 4100 Series Next-Generation Firewalls: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

Firepower 9300 Security Appliance: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

  • MDS 9000 Series Multilayer Switches: CSCvd69962
  • 5.2 migrate to version 8.1(2) or 8.2(1)
  • 6.2 migrate to version 8.1(2) or 8.2(1)
  • 7.3 migrate to version 8.1(2) or 8.2(1)
  • 8.1 migrate to version 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 3000 Series Switches: CSCve02810

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 3500 Platform Switches: CSCve02808

  • 6.0 migrate to 7.0(3)I7(2) or 7.0(3)I7(4)
  • 7.0.3 is not vulnerable

 

Nexus 2000 Series Fabric Extenders and Nexus 5500, 5600, and 6000 Series Switches: CSCve02822

  • 6.0 migrate to 7.3(3)N1(1)
  • 7.0 migrate to 7.3(3)N1(1)
  • 7.1 migrate to 7.3(3)N1(1)
  • 7.2 migrate to 7.3(3)N1(1)
  • 7.3 migrate to 7.3(3)N1(1)

 

Nexus 7000 Series and 7700 Series Switches: CSCvd69962

  • 6.2 migrate to 6.2(20) or 8.1(2) or 8.2(1)
  • 7.2 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 7.3 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 8.0 migrate to or 8.1(2) or 8.2(1)
  • 8.1 migrate to or 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 9000 Series Switches in standalone NX-OS mode: CSCve02812

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 9500 R-Series Line Cards and Fabric Modules: CSCve02831

  • 7.0 migrate to 7.0(3)F3(1) or 7.0(3)F3(3a)

 

UCS 6100, 6200, and 6300 Series Fabric Interconnects: CSCve02819

  • Prior to 2.2 migrate to 3.2(2b)
  • 2.2 migrate to 3.2(2b)
  • 2.5 migrate to 3.2(2b)
  • 3.0 migrate to 3.2(2b)
  • 3.1 migrate to 3.2(2b)
  • 3.2 migrate to 3.2(2b)

Further Information

Cisco’s security advisory for this vulnerability can be found here

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fx-os-cli-execution

 

Overview

Cisco has announced a vulnerability in the Cisco Fabric Services (CFS) component of Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated, remote attacker to execute arbitrary code on an affected device.

The vulnerability exists because the affected software insufficiently validates Cisco Fabric Services packet headers when the software processes packet data. An attacker could exploit this vulnerability by sending a maliciously crafted Cisco Fabric Services packet to an affected device. A successful exploit could allow the attacker to cause a buffer overflow condition on the device, which could allow the attacker to execute arbitrary code on the device.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

 

Vulnerable Products

This vulnerability affects the following Cisco products if they are running a vulnerable release of Cisco FXOS Software or Cisco NX-OS Software and are configured to use Cisco Fabric Services:

 

Firepower 4100 Series Next-Generation Firewalls

  • Firepower 9300 Security Appliance
  • MDS 9000 Series Multilayer Switches
  • Nexus 2000 Series Fabric Extenders
  • Nexus 3000 Series Switches
  • Nexus 3500 Platform Switches
  • Nexus 5500 Platform Switches
  • Nexus 5600 Platform Switches
  • Nexus 6000 Series Switches
  • Nexus 7000 Series Switches
  • Nexus 7700 Series Switches
  • Nexus 9000 Series Switches in standalone NX-OS mode
  • Nexus 9500 R-Series Line Cards and Fabric Modules
  • UCS 6100 Series Fabric Interconnects
  • UCS 6200 Series Fabric Interconnects
  • UCS 6300 Series Fabric Interconnects

 

Fixed Software Releases

Firepower 4100 Series Next-Generation Firewalls: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

Firepower 9300 Security Appliance: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

MDS 9000 Series Multilayer Switches: CSCvd69943

  • 5.2 migrate to version 8.1(2) or 8.2(1)
  • 6.2 migrate to version 8.1(2) or 8.2(1)
  • 7.3 migrate to version 8.1(2) or 8.2(1)
  • 8.1 migrate to version 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 3000 Series Switches: CSCve02429

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 3500 Platform Switches: CSCve02429

  • 6.0 migrate to 7.0(3)I7(2) or 7.0(3)I7(4)
  • 7.0.3 is not vulnerable

 

Nexus 2000 Series Fabric Extenders and Nexus 5500, 5600, and 6000 Series Switches: CSCve02435

  • 6.0 migrate to 7.1(5)N1(1) or 7.3(3)N1(1)
  • 7.0 migrate to 7.1(5)N1(1) or 7.3(3)N1(1)
  • 7.1 migrate to 7.1(5)N1(1) or 7.3(3)N1(1)
  • 7.2 migrate to 7.3(3)N1(1)
  • 7.3 migrate to 7.3(3)N1(1)

 

Nexus 7000 Series and 7700 Series Switches: CSCvd69943

  • 6.2 migrate to 6.2(20) or 8.1(2) or 8.2(1)
  • 7.2 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 7.3 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 8.0 migrate to or 8.1(2) or 8.2(1)
  • 8.1 migrate to or 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 9000 Series Switches in standalone NX-OS mode: CSCve02429

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 9500 R-Series Line Cards and Fabric Modules: CSCve02445

  • 7.0 migrate to 7.0(3)F3(1) or 7.0(3)F3(3a)

UCS 6100, 6200, and 6300 Series Fabric Interconnects: CSCve02433

  • Prior to 2.2 migrate to 3.2(1d) or 3.2(2b)
  • 2.2 migrate to 3.2(1d) or 3.2(2b)
  • 2.5 migrate to 3.2(1d) or 3.2(2b)
  • 3.0 migrate to 3.2(1d) or 3.2(2b)
  • 3.1 migrate to 3.2(1d) or 3.2(2b)
  • 3.2 migrate to 3.2(1d) or 3.2(2b)

 

Further Information

Cisco’s security advisory for this vulnerability can be found here https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fx-os-fabric-execution

 

Overview

Cisco has announced a vulnerability in the Cisco Fabric Services component of Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated, remote attacker to execute arbitrary code or cause a denial of service (DoS) condition.

The vulnerability exists because the affected software insufficiently validates header values in Cisco Fabric Services packets. An attacker could exploit this vulnerability by sending a crafted Cisco Fabric Services packet to an affected device. A successful exploit could allow the attacker to cause a buffer overflow that could allow the attacker to execute arbitrary code or cause a DoS condition.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

 

Vulnerable Products

This vulnerability affects the following Cisco products if they are running a vulnerable release of Cisco FXOS Software or Cisco NX-OS Software and are configured to use Cisco Fabric Services:

 

Firepower 4100 Series Next-Generation Firewalls

  • Firepower 9300 Security Appliance
  • MDS 9000 Series Multilayer Switches
  • Nexus 2000 Series Fabric Extenders
  • Nexus 3000 Series Switches
  • Nexus 3500 Platform Switches
  • Nexus 5500 Platform Switches
  • Nexus 5600 Platform Switches
  • Nexus 6000 Series Switches
  • Nexus 7000 Series Switches
  • Nexus 7700 Series Switches
  • Nexus 9000 Series Switches in standalone NX-OS mode
  • Nexus 9500 R-Series Line Cards and Fabric Modules
  • UCS 6100 Series Fabric Interconnects
  • UCS 6200 Series Fabric Interconnects
  • UCS 6300 Series Fabric Interconnects

 

Fixed Software Releases

Firepower 4100 Series Next-Generation Firewalls: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

Firepower 9300 Security Appliance: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

MDS 9000 Series Multilayer Switches: CSCvd69954

  • 5.2 migrate to version 8.1(2) or 8.2(1)
  • 6.2 migrate to version 8.1(2) or 8.2(1)
  • 7.3 migrate to version 8.1(2) or 8.2(1)
  • 8.1 migrate to version 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 3000 Series Switches: CSCve02785

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 3500 Platform Switches: CSCve02785

  • 6.0 migrate to 7.0(3)I7(2) or 7.0(3)I7(4)
  • 7.0.3 is not vulnerable

 

Nexus 2000, 5500, 5600, and 6000 Series Switches: CSCve02463

  • 6.0 migrate to 7.3(3)N1(1)
  • 7.0 migrate to 7.3(3)N1(1)
  • 7.1 migrate to 7.3(3)N1(1)
  • 7.2 migrate to 7.3(3)N1(1)
  • 7.3 migrate to 7.3(3)N1(1)

Nexus 7000 and 7700 Series Switches: CSCvd69954

  • 6.2 migrate to 6.2(20) or 8.1(2) or 8.2(1)
  • 7.2 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 7.3 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 8.0 migrate to or 8.1(2) or 8.2(1)
  • 8.1 migrate to or 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 9000 Series Switches in standalone NX-OS mode: CSCve02785

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I6(2) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 9500 R-Series Line Cards and Fabric Modules: CSCve02804

  • 7.0 migrate to 7.0(3)F3(1) or 7.0(3)F3(3a)

 

UCS 6100, 6200, and 6300 Fabric Interconnects: CSCve02787

  • Prior to 2.2 migrate to 3.2(2b)
  • 2.2 migrate to 3.2(2b)
  • 2.5 migrate to 3.2(2b)
  • 3.0 migrate to 3.2(2b)
  • 3.1 migrate to 3.2(2b)
  • 3.2 migrate to 3.2(2b)

 

Further Information

Cisco’s security advisory for this vulnerability can be found here

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxnxos-fab-ace

 

Overview

Cisco has announced a vulnerability in the Cisco Fabric Services component of Cisco FXOS Software and Cisco NX-OS Software could allow an unauthenticated, remote attacker to read sensitive memory content, create a denial of service (DoS) condition, or execute arbitrary code as root.

The vulnerability exists because the affected software insufficiently validates Cisco Fabric Services packet headers. An attacker could exploit this vulnerability by sending a crafted Cisco Fabric Services packet to an affected device. A successful exploit could allow the attacker to cause a buffer overflow or buffer overread condition in the Cisco Fabric Services component, which could allow the attacker to read sensitive memory content, create a DoS condition, or execute arbitrary code as root.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

 

Vulnerable Products

This vulnerability affects the following Cisco products if they are running a vulnerable release of Cisco FXOS Software or Cisco NX-OS Software and are configured to use Cisco Fabric Services:

  • Firepower 4100 Series Next-Generation Firewalls
  • Firepower 9300 Security Appliance
  • MDS 9000 Series Multilayer Switches
  • Nexus 2000 Series Fabric Extenders
  • Nexus 3000 Series Switches
  • Nexus 3500 Platform Switches
  • Nexus 5500 Platform Switches
  • Nexus 5600 Platform Switches
  • Nexus 6000 Series Switches
  • Nexus 7000 Series Switches
  • Nexus 7700 Series Switches
  • Nexus 9000 Series Switches in standalone NX-OS mode
  • Nexus 9500 R-Series Line Cards and Fabric Modules
  • UCS 6100 Series Fabric Interconnects
  • UCS 6200 Series Fabric Interconnects
  • UCS 6300 Series Fabric Interconnects

 

Fixed Software Releases

Firepower 4100 Series Next-Generation Firewalls: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

Firepower 9300 Security Appliance: CSCve04859

  • 1.1 migrate to 1.1.4.179 or 2.2.2.17 or 2.3.1.58
  • 2.0 migrate to 2.0.1.153 or 2.2.2.17 or 2.3.1.58
  • 2.1.1 migrate to 2.1.1.86 or 2.2.2.17 or 2.3.1.58
  • 2.2.1 migrate to 2.2.1.70 or 2.2.2.17 or 2.3.1.58
  • 2.2.2 migrate to 2.2.2.17 or 2.2.2.17 or 2.3.1.58
  • 2.3 is not vulnerable

 

MDS 9000 Series Multilayer Switches: CSCvd69951

  • 5.2 migrate to version 8.1(2) or 8.2(1)
  • 6.2 migrate to version 8.1(2) or 8.2(1)
  • 7.3 migrate to version 8.1(2) or 8.2(1)
  • 8.1 migrate to version 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 3000 Series Switches: CSCve02459

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 3500 Platform Switches: CSCve02459

  • 6.0 migrate to 7.0(3)I7(2) or 7.0(3)I7(4)
  • 7.0.3 is not vulnerable

 

Nexus 2000, 5500, 5600, and 6000 Series Switches: CSCve02463

  • 6.0 migrate to 7.3(3)N1(1)
  • 7.0 migrate to 7.3(3)N1(1)
  • 7.1 migrate to 7.3(3)N1(1)
  • 7.2 migrate to 7.3(3)N1(1)
  • 7.3 migrate to 7.3(3)N1(1)

 

Nexus 7000 and 7700 Series Switches: CSCvd69951

  • 6.2 migrate to 6.2(20) or 8.1(2) or 8.2(1)
  • 7.2 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 7.3 migrate to 7.3(2)D1(1) or 8.1(2) or 8.2(1)
  • 8.0 migrate to or 8.1(2) or 8.2(1)
  • 8.1 migrate to or 8.1(2) or 8.2(1)
  • 8.2 is not vulnerable

 

Nexus 9000 Series Switches in standalone NX-OS mode: CSCve02459

  • Prior to 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I4 migrate to 7.0(3)I4(7) or 7.0(3)I7(4)
  • 7.0(3)I5 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I6 migrate to 7.0(3)I7(1) or 7.0(3)I7(4)
  • 7.0(3)I7 is not vulnerable

 

Nexus 9500 R-Series Line Cards and Fabric Modules: CSCve02474

  • 7.0 migrate to 7.0(3)F3(1) or 7.0(3)F3(3a)

 

UCS 6100, 6200, and 6300 Series Fabric Interconnects: CSCve02461

  • Prior to 2.2 migrate to 3.2(2b)
  • 2.2 migrate to 3.2(2b)
  • 2.5 migrate to 3.2(2b)
  • 3.0 migrate to 3.2(2b)
  • 3.1 migrate to 3.2(2b)
  • 3.2 migrate to 3.2(2b)

 

Further Information

Cisco’s security advisory for this vulnerability can be found here

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxnxos-ace

Should you have any queries at all, please don’t hesitate to contact our Security & Vulnerability Team

BLOCKResponse@block.co.uk